Единое окно доступа к образовательным ресурсам

Компьютерные технологии в металлургии и литейном производстве: Учебное пособие. Часть 1

Голосов: 2

В 1 части учебного пособия описаны методики решения типовых задач в области металлургии и литейного производства с применением современных средств вычислительной техники. Представлены практические приемы использования персональных компьютеров и существующего программного обеспечения для решения таких задач. Пособие предназначено для студентов специальности 110400 - "Литейное производство черных и цветных металлов" (специализация 110409 - "Литейное производство и экономика металлургии"). Оно может быть использовано студентами специальности 060800 - "Экономика и управление на предприятии" (специализация 060802 - "Экономика и управление на предприятиях металлургии"), а также слушателями факультета повышения квалификации профессорско-преподавательского состава, аспирантами, инженерами и всеми, кто желает в короткое время освоить персональный компьютер и использовать его в своей повседневной деятельности.

Приведенный ниже текст получен путем автоматического извлечения из оригинального PDF-документа и предназначен для предварительного просмотра.
Изображения (картинки, формулы, графики) отсутствуют.
                                        111


                                x4 ≤ 0,01                       (12.3)

       Таблица 12.4. Расчет оптимального состава шихты

       A      B    C     D      E         F   G    H       I   J      K
1    Наи-
     мено-                   Переменные:
     вание
2    Ком-
     понен-    x1   x2    x3     x4    x5   x6     x7     ЦФ   Вид
     ты
3    Нач.
     значе-    1     1     1     1     1     1      1          min
     ния
4    Цена,    920 580 2890 865 9800 2500          34760
     руб/т                                   0
     Эле-                                                 Лев Сим- Пр.
5    мен-                    Ограничения:                 ч.  вол   ч.
     ты:
 6      С     0,24 0,41 3,85 69,7 0,10      7,0    1,5          ≥    0,67
 7      С     0,24 0,41 3,85 69,7 0,10      7,0    1,5          ≤    0,75
 8      Si      0    0    0      0    69,3 0,90    2,25         ≥    0,17
 9      Si      0    0    0      0    69,3 0,90    2,25         ≤    0,37
10     Mn     0,20 0,60 0,85     0    0,38 71,3   80,75         ≥    0,50
11     Mn     0,20 0,60 0,85     0    0,38 71,3   80,75         ≤    0,80
12      P     0,03 0,02 0,08     0    0,04 0,03    0,03         ≤    0,04
13      S     0,04 0,03 0,05 0,72 0,02 0,03       0,03          ≤    0,04
14   Воз-            1                                          ≤    0,15
     врат
15   Кокс                        1                              ≤    0,01
16   Сумма     1     1    1      1     1     1     1            =     1
17         Итого элементный состав шихты, %
18             C    Si    Mn     P     S
19


                                 112

    Формальным ограничением является условие

                           n

                          ∑x
                          j =1
                                  j    =1                (12.4)


       Система электронных таблиц Excel располагает встроен-
ными средствами решения задач линейного, а также нелиней-
ного и стохастического программирования как в непрерывной,
так и в целочисленной постановке [24]. Для реализации этих
средств загрузим Excel и запишем условия нашей задачи по
форме табл. 12.4. Здесь, в столбце, отведённом для каждого
компонента xj шихты приводим содержание в нём химических
элементов с учётом степени их усвоения, причем для каждого
элемента при наличии двухсторонних его ограничений это со-
держание должно быть записано дважды: один раз – в строке
со знаком ограничения « ≥ », а другой раз – в строке со знаком
« ≤ ». Формулы в ячейках таблицы, как и выше, записываем по
правилам, принятым разработчиками Excel.
       Диапазон B3:H3 заполняем начальными приближениями
значений переменных x1 … x7 , равными, например, единице. От
них в процессе решения осуществляется поиск оптимума.
    В ячейку I3 вписываем формулу целевой функции

    =B3∗B4+C3∗C4+D3∗D4+E3∗E4+F3∗F4+G3∗G4+H3∗H4
                                                        (12.5)

    Вместо этой формулы можно ввести более компактную
функцию из набора встроенных =СУММПРОИЗВ(B3:H3; B4:H4),
выражающую произведение векторов B3:H3 и B4:H4 как сум-
му почленных произведений их элементов. В диапазон I6:I16
вносим формулы левых частей ограничений по схеме

        Ячейка                          Формула

          I6             = СУММПРОИЗВ(B3:H3; B6:H6)
          I7             = СУММПРОИЗВ(B3:H3; B7:H7)
          I8             = СУММПРОИЗВ(B3:H3; B8:H8)
          I9             = СУММПРОИЗВ(B3:H3; B9:H9)


                            113

          I10           = СУММПРОИЗВ (B3:H3; B10:H10)
          I11           = СУММПРОИЗВ (B3:H3; B11:H11)
          I12           = СУММПРОИЗВ (B3:H3; B12:H12)
          I13           = СУММПРОИЗВ (B3:H3; B13:H13)
          I14           =C3∗C14
          I15           =E3∗E15
          I16           =СУММ(B3:H3).

     Таблицу рекомендуется сохранить. Её можно дополнить
проверочным расчётом элементного состава шихты, для чего
ввести формулы содержания в ней химических элементов

           Ячейка                     Формула

            B19            =СУММПРОИЗВ(B3:H3;B6:H6)
            C19            =СУММПРОИЗВ(B3:H3;B8:H8)
            D19            =СУММПРОИЗВ(B3:H3;B10:H10)
            E19            =СУММПРОИЗВ(B3:H3;B12:H12)
            F19            =СУММПРОИЗВ(B3:H3;B13:H13)

    Далее командой

                     Сервис | Поиск решения

вызываем окно «Поиск решения» и выполняем в нём сле-
дующие манипуляции:

     - вводим имя ячейки целевой функции (I3), которой нуж-
но придать минимальное значение, изменяя содержимое яче-
ек B3:H3;
    - действием [1Л] на кнопке [Добавить] вызываем следую-
щее окно, специально предназначенное для ввода ограниче-
ний и указываем эти ограничения. Закончив ввод ограниче-
ний, делаем [1Л] на кнопке [OK] и возвращаемся в окно По-
иск решения;
     - щёлкаем [1Л] на кнопке [Параметры] и в этом окне
задаём требуемую информацию:

  − линейная модель;


                               114

      − неотрицательные значения;
    оценка    линейная;
    разности    прямые;
    метод поиска    Ньютона.

       Остальные параметры − по умолчанию. Закончив установку
    параметров, вводим [1Л] на кнопке [OK] и возвращаемся в
    окно Поиск решения;
-      - запускаем задачу на решение, сделав [1Л] на кнопке
    [Выполнить].
-      После завершения счёта на экране монитора возникает
    окно «Результаты поиска решения». При отсутствии ошибок в
    этом окне сообщается: «Решение найдено. Все ограничения и
    условия оптимальности выполнены» с предложением либо
    сохранить найденное решение, либо восстановить исходные
    данные». Очевидно, последнее необходимо при поиске причин
    несовместности в составе исходных данных и отладке задачи.
    Нужное действие следует задать установкой флажка     с по-
    мощью мыши. В случае успеха результат решения рассмат-
    риваемой задачи представляется в процентах:
-
        x1 = 83,87;
        x2 = 15,00;
        x3 = 0;
        x4 = 0,55;
        x5 = 0,24;
        x6 = 0,34;
        x7 = 0.

          Эти данные, выраженные в массовых долях компонентов
    шихты, возникают на местах бывших единиц в диапазоне
    ячеек B3:H3 (табл.12.4). Они означают, что в оптимальном
    наборе шихты должно содержаться 83,87 % привозного
    стального лома, 15 % возврата собственного производства и
    т.д. По данным расчёта не следует применять передельный
    чугун и малоуглеродистый ферромарганец, расчётные содер-
    жания которых оказались равными нулю.


                             115

    При этом получаем элементный химический состав ших-
ты в процентах (диапазон ячеек B19:F19):

    C = 0,67;
    Si = 0,17;
    Mn =0,50;
    P = 0,03;
    S = 0,04,

что соответствует условиям задачи. При этом искомое − ми-
нимальное значение целевой функции (цены шихты) состави-
ло 971,6 руб / т.
     Сохраненная табл.12.4 в дальнейшем позволяет варьи-
ровать исходные данные и выявлять их влияние на резуль-
тирующие технико-экономические показатели производства.
     Заметим, что наша задача решена в непрерывной поста-
новке.
     Итогом ее являются смешанные числа значений искомых x1,
… , x7, содержащие целую и дробную часть.
     И еще одно замечание: в задачах математического прог-
раммирования данные, представленные по форме табл.12.4, по
существу, являются оптимизационной математической моде-
лью данной системы.
     Особенности расчёта оптимального состава шихты для
выплавки цветных сплавов изложены в [23].


          13. РАСЧЁТ ОПТИМАЛЬНОГО ПЛАНА
               ПРОИЗВОДСТВА ОТЛИВОК
    Пусть литейное предприятие способно выпускать отливки
четырёх возможных видов, обозначенных как отл1, отл2, отл3 и
отл4 при наличии ограничений трёх видов: трудовых, сырьевых
и финансовых (табл. 13.1, с. 116). Эти ресурсы, за исключением
трудовых в пределах имеющегося штата основных производст-
венных рабочих (120 чел.) выражены в отвлечённых единицах,
что не влияет на общую методику решения подобных задач:


                             116

    Таблица 13.1. Оптимизация технико – экономических
показателей процесса производства отливок

          A        B    C    D    E       F     G       H
  1                ПЕРЕМЕННЫЕ :
  2 Наименова-    отл1 отл2 отл3 отл4   ЦФ     вид
    ние
  3 Начальное        1   1   1     1
    знач.
  4                                Прибыль max
  5 Прибыль.         90 65 101 125         макс.
  6                  ОГРАНИЧЕНИЯ :
  7 Вид                             Лев.ч. Знак       Прав.ч.
  8 Трудовые         12  9  11 16           <=         120
  9 Сырьевые          8  6   7  5           <=         111
 10 Финансовые        9  7  11 15           <=         182


                         сырьё   ≤ 111,
                         финансы ≤ 182.

   Известна прибыль от реализации отливки каждого вида, а
именно:
       Вид отливки            Прибыль в отвлечённых
                                    единицах
           Отл1                           90
           Отл2                           65
           Отл3                         101
           Отл4                         125.

      Требуется найти оптимальный план выпуска отливок, обес-
печивающий максимальную в условиях задачи прибыль предпри-
ятия.


                             117

                            Решение
     Процесс решения данной задачи с использованием Excel
в основном аналогичен описанному в предыдущем разделе.
Единственным (и принципиальным) отличием здесь является
условие целочисленности искомых, оптимальных, значений
переменных отл1, … , отл4. Грубой ошибкой было бы предпо-
ложение о том, что можно применить метод линейного (или
нелинейного ) программирования в непрерывной постановке, а
найденные решения в виде смешанных чисел округлить до
целых. Такой результат мог бы быть весьма далёким от оп-
тимального. Действия выполняем в следующем порядке.
     Заполняем таблицу исходными данными. Поскольку задвча
решается итерационной процедурой, в качестве начальных
значений плана (диапазон B3: E3) выпуска каждого вида отливок
принимаем, как и выше, их единичные значения. От этих значе-
ний в дальнейшем осуществляется поиск оптимального решения.
    Цифры диапазона B8:E10 характеризуют расход ресурсов
на производство одной отливки каждого вида.
   Прибыль от реализации одной отливки каждого вида вно-
сим в диапазон B5:E5.
   В ячейку F5 записываем формулу целевой функции - размер
прибыли от реализации отливок:

                    = СУММПРОИЗВ(B3:E3;B5:E5)
выражающую произведение векторов B3:E3 и B5:E5 как сумму
почленных произведений соответствующих по порядковому но-
меру их элементов, что равносильно записи
                    = B3*B5+C3*C5+D3*D5+E3*E5
В ячейки F8:F10 левых частей рассматриваемых ограничений
следует записать:
           Ячейка                      Функция
             F8            =СУММПРОИЗВ(B3:E3;B8:E8)


                              118

             F9             =СУММПРОИЗВ(B3:E3;B9:E9)
             F10            =СУММПРОИЗВ(B3:E3;B10:E10)


   Далее командой
                     Сервис Поиск Решения
вызываем окно «Поиск решения», в которое вводим:

      - имя ячейки целевой функции (F5), которой следует придать
максимальное значение, изменяя содержимое ячеек B3:E3;
      - делаем [1Л] на кнопке [Добавить] и вводим ограниче-
ния
                     F8 ≤ H8
                     F9 ≤ H9
                     F10 ≤ H10
кроме того, здесь же указываем требование целочисленности
                     B3 = цел
                     C3 = цел
                     D3 = цел
                     E3 = цел
      Закончив ввод ограничений, щёлкаем [1Л] на кнопке [OK];
- в окне Параметры указываем:
   - линейная модель;
   - неотрицательные значения;
оценка линейная;
разности прямые;
метод поиска Ньютона;
остальные параметры - по умолчанию;
     В заключение щёлкаем [1Л] на кнопке [OK] и возвраща-
емся в окно «Поиск решения».
    Из окна «Поиск решения» действием [ 1Л ] на кнопке [Вы-
полнить] запускаем задачу на выполнение, после чего прочиты-
ваем найденный оптимальный план выпуска отливок в ячейках
B3:E3 (отл2 − 1 шт., отл3 − 10 шт.), значение достигаемой при
этом прибыли - в ячейке F5 (число 1075), а ниже, в диапазоне


                                  119

F8:F10, результат выполненной компьютером проверки решения
и оценку использования ресурсов.
     Можно усовершенствовать оформление работы, представив
условия задачи на Рабочем листе 1 Excel (по форме табл. 13.1), а
затем скопировать эти условия на Рабочий лист 2 и получить на
нём искомый результат.
    Для копирования нужно выделить блок условий (всю таб-
лицу) курсором или нажатием [ 1Л ] на кнопку, расположенную в
левом верхнем углу Рабочего листа 1, скопировать содержимое в
буфер обмена с помощью кнопки [Копировать] на панели инст-
рументов (см. всплывающие подсказки), перейти на Рабочий лист
2 с помощью указателей в нижней части экрана, установить
курсор в ячейку A1 и вставить из буфера обмена его содержи-
мое во второй Рабочий лист нажатием на кнопку [Вставить].
    Тогда запуск задачи на выполнение осуществляем из Ра-
бочего листа 2 и на нём получаем результат решения.
    Оба рабочих листа содержатся в одном и том же файле,
откуда они могут быть выведены на печать.

             14. ТРАНСПОРТНАЯ ЗАДАЧА
      Сущность так называемой транспортной задачи пояс-
ним на примере. Пусть имеется n складов, хранящих однород-
ную продукцию или материалы в количестве a i единиц каж-
дый, где i – условный номер склада. В то же время сущест-
вуют m потребителей этой продукции, посылающих на склады
заявки bj, причём j − порядковый номер потребителя (заказчи-
ка). Величины ai и bj выражены в единицах измерения про-
дукции или материалов.
      Транспортная задача может быть представлена в двух
возможных вариантах:
      A. Сбалансированный вариант, условием которого являет-
ся

                            n              m

                           ∑a
                           i =1
                                   i   =   ∑b
                                           j =1
                                                  j   ,   (14.1)


                                                  120

Таким образом, в сбалансированной транспортной задаче сум-
ма заявок равна суммарному запасу содержимого складов.
      B. Несбалансированный вариант, отличающийся от cба-
лансированного тем, что из склада может вывозиться не весь
груз, количество которого может превысить заявляемое заказчи-
ком
                                            n           m

                                          ∑a ≥ ∑b
                                           i =1
                                                   i
                                                        j =1
                                                               j



     Если обозначить символом xi j количество груза, вывози-
мое из i - го склада к j - му заказчику, то особенности упомя-
нутых вариантов транспортной задачи могут быть выражены
соотношениями:
      • Сбалансированный вариант
                    m

                   ∑x
                   j =1
                              i j   = ai ; i = 1, n ;              (14.2)

                     n

                    ∑x
                    i =1
                               ij     = b j ; j =1, m ;            (14.3)


       Несбалансированный вариант


                     m

                    ∑x
                    j =1
                                i j       ≤ ai ; i = 1, n ;        (14.4)


                          n

                        ∑x
                        i =1
                                    i j   ≥ b j ; j ≤ 1, m ;       (14.5)


    Из выражений (14.2)…(14.5) следует, что сбалансирован-
ный вариант является частным случаем несбалансированного.
    Решение транспортной задачи направлено на минимиза-
цию суммарной стоимости перевозок [24]. Если цена перевоз-
ки единицы груза с i - го склада к j - му заказчику обозначена



    
Яндекс цитирования Яндекс.Метрика